MC407050 – (Updated) Retirement of Exchange Online PowerShell with MFA

Microsoft Exchange Logo

check before: 2023-01-31

Product:

Azure Active Directory, Exchange

Platform:

Online, World tenant

Status:

Change type:

Admin impact, Retirement, Updated message

Links:

Details:

Updated January 24, 2023: We have updated the timing of this change below.
We will be retiring "the Exchange Online PowerShell module with MFA" on January 31, 2023 (previously December 31, 2022).

Support for the Module will end on August 31, 2022.
We recommend using the Exchange Online PowerShell V2 module (EXO V2 module), which uses modern authentication, and supports accounts with or without MFA.

[Key points:]

Timing:
End of support: August 31, 2022
Retirement: January 31, 2023 (previously December 31, 2022)
Action: Update to the latest version of V2 Module

Change Category:
XXXXXXX ...

Scope:
XXXXXXX ...

Release Phase:

Created:
2022-08-04

updated:
2022-08-27

the free basic plan is required to see all details. Sign up here


A cloudsocut.one plan is required to see all the changed details. If you are already a customer, choose login.
If you are new to cloudscout.one please choose a plan.


changes*

DatePropertyoldnew
2023-01-25MC MessagesWe will be retiring "the Exchange Online PowerShell module with MFA" on December 31, 2022.

Support for the Module will end on August 31, 2022.
We recommend using the Exchange Online PowerShell V2 module (EXO V2 module), which uses modern authentication, and supports accounts with or without MFA.

[Key points:]

Timing:
End of support: August 31, 2022
Retirement: December 31, 2022
Action: Update to the latest version of V2 Module
Updated January 24, 2023: We have updated the timing of this change below.
We will be retiring "the Exchange Online PowerShell module with MFA" on January 31, 2023 (previously December 31, 2022).

Support for the Module will end on August 31, 2022.
We recommend using the Exchange Online PowerShell V2 module (EXO V2 module), which uses modern authentication, and supports accounts with or without MFA.

[Key points:]

Timing:
End of support: August 31, 2022
Retirement: January 31, 2023 (previously December 31, 2022)
Action: Update to the latest version of V2 Module
2023-01-25MC TitleRetirement of Exchange Online PowerShell with MFA(Updated) Retirement of Exchange Online PowerShell with MFA
2023-01-25MC Action Required By12/31/2022 09:00:002023-01-31T09:00:00Z
2023-01-25MC Last Updated07/30/2022 01:38:192023-01-24T22:06:51Z
2023-01-25MC MessageTagNamesAdmin impact, RetirementUpdated message, Admin impact, Retirement
2022-09-15MC prepareWe recommend using the Exchange Online PowerShell V2 module (EXO V2 module), which uses modern authentication, and supports accounts with or without MFA.

For installation and connection instructions, see Install and maintain the EXO V2 module and Connect to Exchange Online PowerShell.
For more information about the different versions of Exchange Online PowerShell modules, see Understanding the Different Versions of Exchange Online PowerShell Modules and Basic Auth.
ps://docs.microsoft.com/powershell/exchange/connect-to-exchange-online-powershell?view=exchange-p
ps://docs.microsoft.com/powershell/exchange/v1-module-mfa-connect-to-exo-powershell?view=exchange-p
ps://techcommunity.microsoft.com/t5/exchange-team-blog/understanding-the-different-versions-of-exchange-online/ba-p/3394487
We recommend using the Exchange Online PowerShell V2 module (EXO V2 module), which uses modern authentication, and supports accounts with or without MFA.

For installation and connection instructions, see Install and maintain the EXO V2 module and Connect to Exchange Online PowerShell.
For more information about the different versions of Exchange Online PowerShell modules, see Understanding the Different Versions of Exchange Online PowerShell Modules and Basic Auth.
https://docs.microsoft.com/powershell/exchange/connect-to-exchange-online-powershell?view=exchange-ps
https://docs.microsoft.com/powershell/exchange/v1-module-mfa-connect-to-exo-powershell?view=exchange-ps
https://techcommunity.microsoft.com/t5/exchange-team-blog/understanding-the-different-versions-of-exchange-online/ba-p/3394487
2022-08-27MC prepareWe recommend using the Exchange Online PowerShell V2 module (EXO V2 module), which uses modern authentication, and supports accounts with or without MFA.

For installation and connection instructions, see Install and maintain the EXO V2 module and Connect to Exchange Online PowerShell.
For more information about the different versions of Exchange Online PowerShell modules, see Understanding the Different Versions of Exchange Online PowerShell Modules and Basic Auth.
https://docs.microsoft.com/powershell/exchange/connect-to-exchange-online-powershell?view=exchange-ps
https://docs.microsoft.com/powershell/exchange/v1-module-mfa-connect-to-exo-powershell?view=exchange-ps
https://techcommunity.microsoft.com/t5/exchange-team-blog/understanding-the-different-versions-of-exchange-online/ba-p/3394487
We recommend using the Exchange Online PowerShell V2 module (EXO V2 module), which uses modern authentication, and supports accounts with or without MFA.

For installation and connection instructions, see Install and maintain the EXO V2 module and Connect to Exchange Online PowerShell.
For more information about the different versions of Exchange Online PowerShell modules, see Understanding the Different Versions of Exchange Online PowerShell Modules and Basic Auth.
ps://docs.microsoft.com/powershell/exchange/connect-to-exchange-online-powershell?view=exchange-p
ps://docs.microsoft.com/powershell/exchange/v1-module-mfa-connect-to-exo-powershell?view=exchange-p
ps://techcommunity.microsoft.com/t5/exchange-team-blog/understanding-the-different-versions-of-exchange-online/ba-p/3394487

*starting April 2022

Last updated 2 days ago

Share to MS Teams

Login to your account

Welcome Back, We Missed You!